Risolto: This setup requires the .NET Framework version 2.0

Risolto il problema del messaggio di errore: This setup requires the .NET Framework version 2.0. Please install the .NET Framework and run this setup again. The .NET Framework can be obtained from the web. Would you like to do this now?


Cercando di installare su Windows 10 applicativi che utilizzano vecchie versioni della piattaforma di sviluppo Microsoft, potreste incorrere nel sopracitato messaggio di errore.

Windows 10 - This setup requires the .NET Framework version 2.0. Please install the .NET Framework and run this setup again.

Rispondendo Yes alla richiesta d’installazione del framework manacnte, si aprirà una finestra per l’installazione di nuove “Funzionalità Windows”. Nello specifico si tratta del .NET Framework 3.5 che include al suo interno anche le librerie .NET 2.0 e 3.0.

Funzionalità Windows .NET Framework 3.5

Cliccando però su “Scarica e installa questa funzionalità” il browser ci indirizzerà ad una pagina del sito ufficiale Microsoft non più disponibile.

L’url per il download infatti pare sia cambiato con il seguente:
https://www.microsoft.com/it-it/download/details.aspx?id=21


Microsoft .NET Framework 3.5 contiene molte nuove funzionalità che ampliano quelle di .NET Framework 2.0 e 3.0 e include .NET Framework 2.0 Service Pack 1 e .NET Framework 3.0 Service Pack 1.

Installando il pacchetto scaricabile dal nuovo link, il setup delle applicazioni in questione dovrebbe riprendere correttamente.
Problema risolto!

Lascia un commento

Il tuo indirizzo email non sarà pubblicato. I campi obbligatori sono contrassegnati *

*